about summary refs log tree commit diff
path: root/modules/hydra.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/hydra.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/modules/hydra.nix b/modules/hydra.nix
index 85b89ab..785e3e9 100644
--- a/modules/hydra.nix
+++ b/modules/hydra.nix
@@ -1,26 +1,25 @@
 { config, lib, ... }:
-with lib;
 let
   cfg = config.nixfiles.modules.hydra;
 in
 {
   options.nixfiles.modules.hydra = {
-    enable = mkEnableOption "Hydra";
+    enable = lib.mkEnableOption "Hydra";
 
-    domain = mkOption {
+    domain = lib.mkOption {
       description = "Domain name sans protocol scheme.";
-      type = with types; str;
+      type = lib.types.str;
       default = "hydra.${config.networking.domain}";
     };
 
-    port = mkOption {
+    port = lib.mkOption {
       description = "Port.";
-      type = with types; port;
+      type = lib.types.port;
       default = 7754;
     };
   };
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     nixfiles.modules = {
       nginx = {
         enable = true;

Consider giving Nix/NixOS a try! <3