about summary refs log tree commit diff
path: root/modules/jackett.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/jackett.nix')
-rw-r--r--modules/jackett.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/modules/jackett.nix b/modules/jackett.nix
index 07a5b16..5b0b2c0 100644
--- a/modules/jackett.nix
+++ b/modules/jackett.nix
@@ -6,22 +6,21 @@
   this,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.jackett;
 in
 {
   options.nixfiles.modules.jackett = {
-    enable = mkEnableOption "Jackett";
+    enable = lib.mkEnableOption "Jackett";
 
-    domain = mkOption {
+    domain = lib.mkOption {
       description = "Domain name sans protocol scheme.";
-      type = with types; str;
+      type = lib.types.str;
       default = "jackett.${config.networking.domain}";
     };
   };
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     ark.directories = [ "/var/lib/jackett" ];
 
     nixfiles.modules.nginx = {

Consider giving Nix/NixOS a try! <3