summaryrefslogtreecommitdiff
path: root/modules/lidarr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/lidarr.nix')
-rw-r--r--modules/lidarr.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/lidarr.nix b/modules/lidarr.nix
index 84d363b..127e8d9 100644
--- a/modules/lidarr.nix
+++ b/modules/lidarr.nix
@@ -3,6 +3,7 @@
inputs,
lib,
libNginx,
+ this,
...
}:
with lib;
@@ -56,5 +57,12 @@ in
systemd.tmpfiles.rules = with config.services.lidarr; [
"d /var/lib/lidarr/root 0755 ${user} ${group} - -"
];
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.lidarr = {
+ info = domain;
+ details.listen.text = "127.0.0.1:8686";
+ };
+ };
};
}