summaryrefslogtreecommitdiff
path: root/modules/matrix/dendrite.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/matrix/dendrite.nix')
-rw-r--r--modules/matrix/dendrite.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/modules/matrix/dendrite.nix b/modules/matrix/dendrite.nix
index dafef00..c391ba0 100644
--- a/modules/matrix/dendrite.nix
+++ b/modules/matrix/dendrite.nix
@@ -1,8 +1,9 @@
{
config,
- lib,
inputs,
+ lib,
pkgs,
+ this,
...
}:
with lib;
@@ -235,5 +236,14 @@ in
];
};
};
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.dendrite = {
+ name = "Dendrite";
+ icon = "${inputs.homelab-svg-assets}/assets/matrix-white.svg";
+ info = domain;
+ details.listen.text = "127.0.0.1:${toString port}";
+ };
+ };
};
}