summaryrefslogtreecommitdiff
path: root/modules/nixfiles/syncthing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixfiles/syncthing.nix')
-rw-r--r--modules/nixfiles/syncthing.nix25
1 files changed, 11 insertions, 14 deletions
diff --git a/modules/nixfiles/syncthing.nix b/modules/nixfiles/syncthing.nix
index 5a973cc..44465d9 100644
--- a/modules/nixfiles/syncthing.nix
+++ b/modules/nixfiles/syncthing.nix
@@ -17,14 +17,14 @@ in {
default = "syncthing.${config.networking.fqdn}";
};
- # TODO Make this simpler.
+ # TODO Set this automatically shire on the hostname.
cert = mkOption {
description = "Path to the cert file.";
type = with types; nullOr string;
default = null;
};
- # TODO Make this simpler.
+ # TODO Set this automatically shire on the hostname.
key = mkOption {
description = "Path to the key file.";
type = with types; nullOr string;
@@ -84,21 +84,14 @@ in {
};
trashcan = {
type = "trashcan";
- params.cleanoutDays = "30";
- };
- void = {
- type = "external";
- params.versionPath = with pkgs;
- writeShellScriptBin "backup" ''
- ${coreutils-full}/bin/rm -rf $1/$2
- '';
+ params.cleanoutDays = "7";
};
in
with config.hm.xdg.userDirs; {
share = {
path = publicShare;
devices = notHeadless;
- versioning = void;
+ versioning = trashcan;
};
pass = {
path =
@@ -124,7 +117,7 @@ in {
vidya = {
path = "${documents}/vidya";
devices = notOther;
- versioning = void;
+ versioning = trashcan;
};
};
@@ -134,9 +127,13 @@ in {
insecureSkipHostcheck = this.isHeadless;
};
options = {
- # Only local discovery is used over VPN.
- globalAnnounceEnabled = false;
+ autoUpgradeIntervalH = 0;
+ crashReportingEnabled = false;
+ globalAnnounceEnabled = false; # We don't need that with Wireguard.
relaysEnabled = false;
+ setLowPriority = this.isHeadless;
+ stunKeepaliveMinS = 0;
+ stunKeepaliveStartS = 0;
urAccepted = -1;
};
};