about summary refs log tree commit diff
path: root/modules/nixos/bluetooth.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/bluetooth.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/modules/nixos/bluetooth.nix b/modules/nixos/bluetooth.nix
index 26d081d..117aff7 100644
--- a/modules/nixos/bluetooth.nix
+++ b/modules/nixos/bluetooth.nix
@@ -1,16 +1,13 @@
-{
-  config,
-  lib,
-  ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
   cfg = config.nixfiles.modules.bluetooth;
-in {
-  options.nixfiles.modules.bluetooth.enable =
-    mkEnableOption "Bluetooth support";
+in
+{
+  options.nixfiles.modules.bluetooth.enable = mkEnableOption "Bluetooth support";
 
   config = mkIf cfg.enable {
-    ark.directories = ["/var/lib/bluetooth"];
+    ark.directories = [ "/var/lib/bluetooth" ];
 
     hardware.bluetooth = {
       enable = true;

Consider giving Nix/NixOS a try! <3