summaryrefslogtreecommitdiff
path: root/modules/nixos/common/networking.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/common/networking.nix')
-rw-r--r--modules/nixos/common/networking.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/modules/nixos/common/networking.nix b/modules/nixos/common/networking.nix
index 0c44159..8d94a4e 100644
--- a/modules/nixos/common/networking.nix
+++ b/modules/nixos/common/networking.nix
@@ -12,6 +12,10 @@ in {
mkEnableOption "custom networking settings";
config = mkIf (!cfg.onlyDefault) {
+ ark.directories = with config.networking;
+ optional networkmanager.enable "/etc/NetworkManager/system-connections"
+ ++ optional wireless.iwd.enable "/var/lib/iwd";
+
# TODO Support multiple interfaces and IP addresses.
networking = mkMerge [
{
@@ -20,8 +24,8 @@ in {
hostName = this.hostname;
hostId = substring 0 8 (builtins.hashString "md5" this.hostname);
- # Remove default hostname mappings. This is required at least by the current
- # implementation of the montoring module.
+ # Remove default hostname mappings. This is required at least by the
+ # current implementation of the monitoring module.
hosts = {
"127.0.0.2" = mkForce [];
"::1" = mkForce [];