about summary refs log tree commit diff
path: root/modules/nixos/common/users.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/common/users.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/modules/nixos/common/users.nix b/modules/nixos/common/users.nix
index 367af41..eca9e1b 100644
--- a/modules/nixos/common/users.nix
+++ b/modules/nixos/common/users.nix
@@ -1,8 +1,10 @@
-{lib, ...}:
-with lib; let
+{ lib, ... }:
+with lib;
+let
   home = "/home/${my.username}";
-in {
-  ark.directories = [home];
+in
+{
+  ark.directories = [ home ];
 
   users = {
     mutableUsers = false;
@@ -16,8 +18,8 @@ in {
         description = my.fullname;
         inherit home;
         inherit (my) hashedPassword;
-        openssh.authorizedKeys.keys = [my.ssh.key];
-        extraGroups = ["wheel"];
+        openssh.authorizedKeys.keys = [ my.ssh.key ];
+        extraGroups = [ "wheel" ];
       };
     };
   };

Consider giving Nix/NixOS a try! <3