about summary refs log tree commit diff
path: root/modules/nixos/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/emacs.nix24
1 files changed, 10 insertions, 14 deletions
diff --git a/modules/nixos/emacs.nix b/modules/nixos/emacs.nix
index c851389..7d2112b 100644
--- a/modules/nixos/emacs.nix
+++ b/modules/nixos/emacs.nix
@@ -7,19 +7,15 @@ with lib; let
   cfg = config.nixfiles.modules.emacs;
 in {
   config = mkIf cfg.enable {
-    nixfiles.modules = {
-      common.xdg.defaultApplications.emacs = [
-        "application/atom+xml"
-        "application/json"
-        "application/rss+xml"
-        "application/schema+json"
-        "application/xhtml+xml"
-        "application/xml"
-        "text/csv"
-        "text/plain"
-      ];
-
-      x11.enable = true;
-    };
+    nixfiles.modules.common.xdg.defaultApplications.emacs = [
+      "application/atom+xml"
+      "application/json"
+      "application/rss+xml"
+      "application/schema+json"
+      "application/xhtml+xml"
+      "application/xml"
+      "text/csv"
+      "text/plain"
+    ];
   };
 }

Consider giving Nix/NixOS a try! <3