about summary refs log tree commit diff
path: root/modules/nixos/firefox/addons.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/firefox/addons.nix83
1 files changed, 43 insertions, 40 deletions
diff --git a/modules/nixos/firefox/addons.nix b/modules/nixos/firefox/addons.nix
index 7936033..bd14bb5 100644
--- a/modules/nixos/firefox/addons.nix
+++ b/modules/nixos/firefox/addons.nix
@@ -4,13 +4,13 @@
 }: {
   "bitwarden" = buildFirefoxXpiAddon {
     pname = "bitwarden";
-    version = "2024.2.0";
+    version = "2024.2.1";
     addonId = "{446900e4-71c2-419f-a6a7-df9c091e268b}";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4233394/bitwarden_password_manager-2024.2.0.xpi";
-    sha256 = "2c59e7040749dee010b34fb2a9c24b28ada71ad7fa5a23264ff70e63f8f686d1";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4246600/bitwarden_password_manager-2024.2.1.xpi";
+    sha256 = "f2db399e5a0915e4fd7e4906c32c72eac4a2b7bb4b4acacd892fff18e73085d4";
     meta = with lib; {
       homepage = "https://bitwarden.com";
-      description = "A secure and free password manager for all of your devices.";
+      description = "At home, at work, or on the go, Bitwarden easily secures all your passwords, passkeys, and sensitive information.";
       license = licenses.gpl3;
       mozPermissions = [
         "<all_urls>"
@@ -33,10 +33,10 @@
   };
   "bypass-paywalls" = buildFirefoxXpiAddon {
     pname = "bypass-paywalls";
-    version = "3.5.5.0";
+    version = "3.5.9.0";
     addonId = "magnolia_limited_permissions_d@12.34";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4235376/bypass_paywalls_clean_d-3.5.5.0.xpi";
-    sha256 = "94357663a92363ebb1fbc662f8b6d1e67909e452e801903b2c85b05d70e46488";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4248144/bypass_paywalls_clean_d-3.5.9.0.xpi";
+    sha256 = "938da8dcfa0e3ff012b40cf54a270ca73b03183387ef9330bf8b7771dbf10a5c";
     meta = with lib; {
       homepage = "https://gitlab.com/magnolia1234/bypass-paywalls-firefox-clean";
       description = "Bypass Paywalls";
@@ -49,7 +49,9 @@
         "webRequestBlocking"
         "*://*.360dx.com/*"
         "*://*.60millions-mag.com/*"
+        "*://*.aargauerzeitung.ch/*"
         "*://*.abc.es/*"
+        "*://*.abendblatt.de/*"
         "*://*.abqjournal.com/*"
         "*://*.abril.com.br/*"
         "*://*.ad.nl/*"
@@ -59,7 +61,6 @@
         "*://*.aerokurier.de/*"
         "*://*.aerztezeitung.de/*"
         "*://*.afr.com/*"
-        "*://*.aisnenouvelle.fr/*"
         "*://*.ajc.com/*"
         "*://*.al.com/*"
         "*://*.allgemeine-zeitung.de/*"
@@ -73,7 +74,6 @@
         "*://*.arabalears.cat/*"
         "*://*.architecturaldigest.com/*"
         "*://*.arcinfo.ch/*"
-        "*://*.arkansasonline.com/*"
         "*://*.artforum.com/*"
         "*://*.artnet.com/*"
         "*://*.artsenkrant.com/*"
@@ -85,6 +85,7 @@
         "*://*.automobilwoche.de/*"
         "*://*.autonews.com/*"
         "*://*.autoplus.fr/*"
+        "*://*.autosport.com/*"
         "*://*.axios.com/*"
         "*://*.azcentral.com/*"
         "*://*.backpacker.com/*"
@@ -116,6 +117,7 @@
         "*://*.bostonglobe.com/*"
         "*://*.bostonherald.com/*"
         "*://*.bqprime.com/*"
+        "*://*.braunschweiger-zeitung.de/*"
         "*://*.brisbanetimes.com.au/*"
         "*://*.britannica.com/*"
         "*://*.buffalonews.com/*"
@@ -126,10 +128,10 @@
         "*://*.businessinsider.nl/*"
         "*://*.businessoffashion.com/*"
         "*://*.businesspost.ie/*"
-        "*://*.businesstimes.com.sg/*"
         "*://*.cairnspost.com.au/*"
         "*://*.calgaryherald.com/*"
         "*://*.cambiocolombia.com/*"
+        "*://*.canarias7.es/*"
         "*://*.canberratimes.com.au/*"
         "*://*.capitalgazette.com/*"
         "*://*.cartacapital.com.br/*"
@@ -171,7 +173,6 @@
         "*://*.courant.com/*"
         "*://*.courier-journal.com/*"
         "*://*.couriermail.com.au/*"
-        "*://*.courrier-picard.fr/*"
         "*://*.crainscleveland.com/*"
         "*://*.crainsdetroit.com/*"
         "*://*.crainsnewyork.com/*"
@@ -196,6 +197,7 @@
         "*://*.demorgen.be/*"
         "*://*.denverpost.com/*"
         "*://*.deraktionaer.de/*"
+        "*://*.desmoinesregister.com/*"
         "*://*.destentor.nl/*"
         "*://*.detroitnews.com/*"
         "*://*.df.cl/*"
@@ -208,7 +210,7 @@
         "*://*.diepresse.com/*"
         "*://*.digiday.com/*"
         "*://*.discovermagazine.com/*"
-        "*://*.dn.se/*"
+        "*://*.dispatch.com/*"
         "*://*.doorbraak.be/*"
         "*://*.dvhn.nl/*"
         "*://*.dwell.com/*"
@@ -254,7 +256,6 @@
         "*://*.euobserver.com/*"
         "*://*.european-rubber-journal.com/*"
         "*://*.europower.no/*"
-        "*://*.ewmagazine.nl/*"
         "*://*.exame.com/*"
         "*://*.examiner.com.au/*"
         "*://*.expansion.com/*"
@@ -274,6 +275,7 @@
         "*://*.flair.nl/*"
         "*://*.flugrevue.de/*"
         "*://*.fnlondon.com/*"
+        "*://*.forbes.com.au/*"
         "*://*.forbes.com/*"
         "*://*.foreignaffairs.com/*"
         "*://*.foreignpolicy.com/*"
@@ -295,16 +297,15 @@
         "*://*.glassdoor.com/*"
         "*://*.globes.co.il/*"
         "*://*.globo.com/*"
+        "*://*.glossy.co/*"
         "*://*.goldcoastbulletin.com.au/*"
         "*://*.goodhousekeeping.com/*"
-        "*://*.gooieneemlander.nl/*"
         "*://*.gq.com/*"
         "*://*.granta.com/*"
         "*://*.groene.nl/*"
         "*://*.grubstreet.com/*"
         "*://*.haaretz.co.il/*"
         "*://*.haaretz.com/*"
-        "*://*.haarlemsdagblad.nl/*"
         "*://*.handelszeitung.ch/*"
         "*://*.harpers.org/*"
         "*://*.harpersbazaar.com/*"
@@ -324,8 +325,6 @@
         "*://*.humanite.fr/*"
         "*://*.humo.be/*"
         "*://*.ideal.es/*"
-        "*://*.ijmuidercourant.nl/*"
-        "*://*.ikz-online.de/*"
         "*://*.ilfattoquotidiano.it/*"
         "*://*.ilfoglio.it/*"
         "*://*.ilgazzettino.it/*"
@@ -336,6 +335,7 @@
         "*://*.ilmessaggero.it/*"
         "*://*.ilrestodelcarlino.it/*"
         "*://*.ilsecoloxix.it/*"
+        "*://*.ilsole24ore.com/*"
         "*://*.iltelegrafolivorno.it/*"
         "*://*.iltirreno.it/*"
         "*://*.inc.com/*"
@@ -364,6 +364,7 @@
         "*://*.irishtimes.com/*"
         "*://*.italian.tech/*"
         "*://*.italiaoggi.it/*"
+        "*://*.jacksonville.com/*"
         "*://*.jacobin.de/*"
         "*://*.janes.com/*"
         "*://*.japantimes.co.jp/*"
@@ -400,7 +401,6 @@
         "*://*.lanouvellerepublique.fr/*"
         "*://*.lanuovasardegna.it/*"
         "*://*.laprovincia.es/*"
-        "*://*.lardennais.fr/*"
         "*://*.larepubliquedespyrenees.fr/*"
         "*://*.larioja.com/*"
         "*://*.lasegunda.com/*"
@@ -412,7 +412,6 @@
         "*://*.lavanguardia.com/*"
         "*://*.lavenir.net/*"
         "*://*.laverdad.es/*"
-        "*://*.lavoixdunord.fr/*"
         "*://*.lavoz.com.ar/*"
         "*://*.lavozdigital.es/*"
         "*://*.law.com/*"
@@ -420,10 +419,8 @@
         "*://*.lecho.be/*"
         "*://*.lecourrierdesstrateges.fr/*"
         "*://*.ledevoir.com/*"
-        "*://*.lefigaro.fr/*"
         "*://*.legrandcontinent.eu/*"
         "*://*.lehighvalleylive.com/*"
-        "*://*.leidschdagblad.nl/*"
         "*://*.lejdd.fr/*"
         "*://*.lemagit.fr/*"
         "*://*.lenouveleconomiste.fr/*"
@@ -433,16 +430,13 @@
         "*://*.lescienze.it/*"
         "*://*.lesechos.fr/*"
         "*://*.lesinrocks.com/*"
-        "*://*.lesoir.be/*"
         "*://*.lesoleil.com/*"
-        "*://*.lest-eclair.fr/*"
         "*://*.letelegramme.fr/*"
         "*://*.levante-emv.com/*"
         "*://*.levif.be/*"
         "*://*.lexpress.fr/*"
         "*://*.libelle.be/*"
         "*://*.libelle.nl/*"
-        "*://*.liberation-champagne.fr/*"
         "*://*.limburger.nl/*"
         "*://*.lindependant.fr/*"
         "*://*.linforme.com/*"
@@ -456,7 +450,7 @@
         "*://*.lopinion.fr/*"
         "*://*.losandes.com.ar/*"
         "*://*.lrb.co.uk/*"
-        "*://*.lunion.fr/*"
+        "*://*.luzernerzeitung.ch/*"
         "*://*.lvz.de/*"
         "*://*.macrobusiness.com.au/*"
         "*://*.madison.com/*"
@@ -482,8 +476,10 @@
         "*://*.mlive.com/*"
         "*://*.moda.it/*"
         "*://*.modernhealthcare.com/*"
+        "*://*.modernretail.co/*"
         "*://*.monacomatin.mc/*"
         "*://*.monocle.com/*"
+        "*://*.morgenpost.de/*"
         "*://*.motorradonline.de/*"
         "*://*.mundodeportivo.com/*"
         "*://*.mv-voice.com/*"
@@ -511,8 +507,6 @@
         "*://*.nikkei.com/*"
         "*://*.nj.com/*"
         "*://*.nola.com/*"
-        "*://*.noordhollandsdagblad.nl/*"
-        "*://*.nordlittoral.fr/*"
         "*://*.northerndailyleader.com.au/*"
         "*://*.northjersey.com/*"
         "*://*.nouvelobs.com/*"
@@ -540,13 +534,13 @@
         "*://*.oregonlive.com/*"
         "*://*.orlandosentinel.com/*"
         "*://*.ostsee-zeitung.de/*"
+        "*://*.otz.de/*"
         "*://*.outdoorlife.com/*"
         "*://*.outlookbusiness.com/*"
         "*://*.outlookindia.com/*"
         "*://*.outsideonline.com/*"
         "*://*.oxygenmag.com/*"
         "*://*.paloaltoonline.com/*"
-        "*://*.paris-normandie.fr/*"
         "*://*.parismatch.com/*"
         "*://*.parool.nl/*"
         "*://*.penews.com/*"
@@ -561,6 +555,7 @@
         "*://*.piqd.de/*"
         "*://*.plasticsnews.com/*"
         "*://*.politicaexterior.com/*"
+        "*://*.polityka.pl/*"
         "*://*.popsci.com/*"
         "*://*.popularmechanics.com/*"
         "*://*.post-gazette.com/*"
@@ -573,7 +568,6 @@
         "*://*.project-syndicate.org/*"
         "*://*.prospectmagazine.co.uk/*"
         "*://*.public.fr/*"
-        "*://*.puck.news/*"
         "*://*.pzc.nl/*"
         "*://*.quora.com/*"
         "*://*.quotidiano.net/*"
@@ -622,9 +616,11 @@
         "*://*.slate.com/*"
         "*://*.slideshare.net/*"
         "*://*.sloanreview.mit.edu/*"
+        "*://*.sltrib.com/*"
         "*://*.smh.com.au/*"
         "*://*.sn.at/*"
         "*://*.sofrep.com/*"
+        "*://*.sourcingjournal.com/*"
         "*://*.spectator.co.uk/*"
         "*://*.spectator.com.au/*"
         "*://*.spglobal.com/*"
@@ -650,15 +646,16 @@
         "*://*.stuttgarter-nachrichten.de/*"
         "*://*.stuttgarter-zeitung.de/*"
         "*://*.stylist.co.uk/*"
-        "*://*.sudinfo.be/*"
         "*://*.sudouest.fr/*"
         "*://*.sueddeutsche.de/*"
+        "*://*.suedkurier.de/*"
         "*://*.sun-sentinel.com/*"
         "*://*.suomensotilas.fi/*"
         "*://*.sustainableplastics.com/*"
         "*://*.svz.de/*"
         "*://*.swarajyamag.com/*"
         "*://*.syracuse.com/*"
+        "*://*.tagblatt.ch/*"
         "*://*.tagesspiegel.de/*"
         "*://*.tampabay.com/*"
         "*://*.techinasia.com/*"
@@ -683,6 +680,7 @@
         "*://*.theaustralian.com.au/*"
         "*://*.thebaffler.com/*"
         "*://*.thebanker.com/*"
+        "*://*.thebookseller.com/*"
         "*://*.thebulletin.org/*"
         "*://*.thechronicle.com.au/*"
         "*://*.thecourier.com.au/*"
@@ -715,6 +713,7 @@
         "*://*.thesaturdaypaper.com.au/*"
         "*://*.thespec.com/*"
         "*://*.thespectator.com/*"
+        "*://*.thestage.co.uk/*"
         "*://*.thestar.com/*"
         "*://*.thestate.com/*"
         "*://*.thetimes.co.uk/*"
@@ -722,11 +721,13 @@
         "*://*.theweek.com/*"
         "*://*.thewest.com.au/*"
         "*://*.thewrap.com/*"
+        "*://*.thueringer-allgemeine.de/*"
         "*://*.tijd.be/*"
         "*://*.timeshighereducation.com/*"
         "*://*.timesofindia.com/*"
         "*://*.timesunion.com/*"
         "*://*.tirebusiness.com/*"
+        "*://*.tlz.de/*"
         "*://*.topagrar.com/*"
         "*://*.torontosun.com/*"
         "*://*.towardsdatascience.com/*"
@@ -758,6 +759,7 @@
         "*://*.vikatan.com/*"
         "*://*.vn.at/*"
         "*://*.vn.nl/*"
+        "*://*.vogue.co.uk/*"
         "*://*.vogue.com/*"
         "*://*.voguebusiness.com/*"
         "*://*.vol.at/*"
@@ -837,6 +839,7 @@
         "*://*.nhst.tech/*"
         "*://*.nyt.com/*"
         "*://*.pasedigital.cl/*"
+        "*://*.wbmdstatic.com/*"
         "*://*.wgchrrammzv.com/*"
         "*://*.wyleex.com/*"
         "*://archive.fo/*"
@@ -853,24 +856,24 @@
   };
   "consent-o-matic" = buildFirefoxXpiAddon {
     pname = "consent-o-matic";
-    version = "1.0.12";
+    version = "1.0.13";
     addonId = "gdpr@cavi.au.dk";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4074847/consent_o_matic-1.0.12.xpi";
-    sha256 = "013ea48757b8a4d84a2a0d944bc49b5612d62bae1d337f9569f425f2b8310e0f";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4246350/consent_o_matic-1.0.13.xpi";
+    sha256 = "ee577eaedebd9fef65f77218b86c59972818442c9af551d551a7015a4a246e9a";
     meta = with lib; {
       homepage = "https://consentomatic.au.dk/";
       description = "Automatic handling of GDPR consent forms";
       license = licenses.mit;
-      mozPermissions = ["activeTab" "storage" "<all_urls>"];
+      mozPermissions = ["activeTab" "tabs" "storage" "<all_urls>"];
       platforms = platforms.all;
     };
   };
   "darkreader" = buildFirefoxXpiAddon {
     pname = "darkreader";
-    version = "4.9.77";
+    version = "4.9.78";
     addonId = "addon@darkreader.org";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4233074/darkreader-4.9.77.xpi";
-    sha256 = "931de67e9091c69edd9fd3f348a7ed1de1dce7d136017fed641bd10eb0ae8891";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4243182/darkreader-4.9.78.xpi";
+    sha256 = "21e08b3f26e9b54257d30f6b2fb2d966d41ace54d2d79ccec55e55517084c7ce";
     meta = with lib; {
       homepage = "https://darkreader.org/";
       description = "Dark mode for every website. Take care of your eyes, use dark theme for night and daily browsing.";
@@ -996,10 +999,10 @@
   };
   "rikaichamp" = buildFirefoxXpiAddon {
     pname = "rikaichamp";
-    version = "1.17.1";
+    version = "1.18.0";
     addonId = "{59812185-ea92-4cca-8ab7-cfcacee81281}";
-    url = "https://addons.mozilla.org/firefox/downloads/file/4216725/10ten_ja_reader-1.17.1.xpi";
-    sha256 = "f9ff2420341adc2e3ea59c8c28271cc03c4c09f2467cbe59215804d62660fa8b";
+    url = "https://addons.mozilla.org/firefox/downloads/file/4241410/10ten_ja_reader-1.18.0.xpi";
+    sha256 = "5433bcfec5a327bf1fa198b3f0645a9cdcdc44232465ad940fa8a5858b6996f8";
     meta = with lib; {
       homepage = "https://github.com/birchill/10ten-ja-reader/";
       description = "Quickly translate Japanese by hovering over words. Formerly released as Rikaichamp.";

Consider giving Nix/NixOS a try! <3