about summary refs log tree commit diff
path: root/modules/nixos/firefox/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/firefox/default.nix49
1 files changed, 25 insertions, 24 deletions
diff --git a/modules/nixos/firefox/default.nix b/modules/nixos/firefox/default.nix
index 4c9437c..4c36d74 100644
--- a/modules/nixos/firefox/default.nix
+++ b/modules/nixos/firefox/default.nix
@@ -34,32 +34,32 @@ in {
             mkMerge [
               (with config.colourScheme; ''
                 :root {
-                    --black: ${black};
-                    --red: ${red};
-                    --green: ${green};
-                    --yellow: ${yellow};
-                    --blue: ${blue};
-                    --magenta: ${magenta};
-                    --cyan: ${cyan};
-                    --white: ${white};
-                    --bright-black: ${brightBlack};
-                    --bright-red: ${brightRed};
-                    --bright-green: ${brightGreen};
-                    --bright-yellow: ${brightYellow};
-                    --bright-blue: ${brightBlue};
-                    --bright-magenta: ${brightMagenta};
-                    --bright-cyan: ${brightCyan};
-                    --bright-white: ${brightWhite};
-                    --background: ${background};
-                    --foreground: ${foreground};
+                  --black: ${black};
+                  --red: ${red};
+                  --green: ${green};
+                  --yellow: ${yellow};
+                  --blue: ${blue};
+                  --magenta: ${magenta};
+                  --cyan: ${cyan};
+                  --white: ${white};
+                  --bright-black: ${brightBlack};
+                  --bright-red: ${brightRed};
+                  --bright-green: ${brightGreen};
+                  --bright-yellow: ${brightYellow};
+                  --bright-blue: ${brightBlue};
+                  --bright-magenta: ${brightMagenta};
+                  --bright-cyan: ${brightCyan};
+                  --bright-white: ${brightWhite};
+                  --background: ${background};
+                  --foreground: ${foreground};
               '')
               (with config.fontScheme; ''
-                    --sans-serif-font-family: "${sansSerifFont.family}", "${sansSerifFontFallback.family}", sans-serif;
-                    --sans-serif-font-size: ${toString sansSerifFont.size}px;
-                    --serif-font-family: "${serifFont.family}", "${serifFontFallback.family}", serif;
-                    --serif-font-size: ${toString serifFont.size}px;
-                    --monospace-font-family: "${monospaceFont.family}", "${monospaceFontFallback.family}", monospace;
-                    --monospace-font-size: ${toString monospaceFont.size}px;
+                  --sans-serif-font-family: "${sansSerifFont.family}", "${sansSerifFontFallback.family}", sans-serif;
+                  --sans-serif-font-size: ${toString sansSerifFont.size}px;
+                  --serif-font-family: "${serifFont.family}", "${serifFontFallback.family}", serif;
+                  --serif-font-size: ${toString serifFont.size}px;
+                  --monospace-font-family: "${monospaceFont.family}", "${monospaceFontFallback.family}", monospace;
+                  --monospace-font-size: ${toString monospaceFont.size}px;
                 }
               '')
               (builtins.readFile css)
@@ -572,6 +572,7 @@ in {
             "browser.toolbars.bookmarks.visibility" = "newtab";
             "browser.translations.enable" = false;
             "browser.urlbar.decodeURLsOnCopy" = true;
+            "browser.urlbar.suggest.engines" = false;
             "browser.warnOnQuitShortcut" = false;
             "devtools.everOpened" = true;
             "doh-rollout.home-region" = "US";

Consider giving Nix/NixOS a try! <3