summaryrefslogtreecommitdiff
path: root/modules/nixos/games/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/default.nix')
-rw-r--r--modules/nixos/games/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/modules/nixos/games/default.nix b/modules/nixos/games/default.nix
new file mode 100644
index 0000000..1c5766b
--- /dev/null
+++ b/modules/nixos/games/default.nix
@@ -0,0 +1,38 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.games;
+in {
+ imports = [
+ ./gamemode.nix
+ ./gog.nix
+ ./lutris.nix
+ ./mangohud.nix
+ ./minecraft.nix
+ ./steam-run.nix
+ ./steam.nix
+ ];
+
+ options.nixfiles.modules.games.enable32BitSupport =
+ mkEnableOption "support for games";
+
+ config = mkIf cfg.enable32BitSupport {
+ services = {
+ jack.alsa.support32Bit = config.services.jack.alsa.enable;
+
+ pipewire.alsa.support32Bit = config.services.pipewire.alsa.enable;
+ };
+
+ hardware = {
+ opengl = mkIf config.hardware.opengl.enable {
+ extraPackages32 = config.hardware.opengl.extraPackages;
+ driSupport32Bit = config.hardware.opengl.driSupport;
+ };
+
+ pulseaudio.support32Bit = config.hardware.pulseaudio.enable;
+ };
+ };
+}