about summary refs log tree commit diff
path: root/modules/nixos/games/gamemode.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/games/gamemode.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/modules/nixos/games/gamemode.nix b/modules/nixos/games/gamemode.nix
index 051d12e..193a764 100644
--- a/modules/nixos/games/gamemode.nix
+++ b/modules/nixos/games/gamemode.nix
@@ -9,5 +9,11 @@ in {
   options.nixfiles.modules.games.gamemode.enable =
     mkEnableOption "Feral GameMode";
 
-  config = mkIf cfg.enable {programs.gamemode.enable = true;};
+  config = mkIf cfg.enable {
+    hm.xdg.configFile."gamemode.ini".text = generators.toINI {} {
+      general.softrealtime = "auto";
+    };
+
+    programs.gamemode.enable = true;
+  };
 }

Consider giving Nix/NixOS a try! <3