about summary refs log tree commit diff
path: root/modules/nixos/games/steam-run.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/games/steam-run.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/modules/nixos/games/steam-run.nix b/modules/nixos/games/steam-run.nix
index 4540e3f..2643c95 100644
--- a/modules/nixos/games/steam-run.nix
+++ b/modules/nixos/games/steam-run.nix
@@ -11,6 +11,7 @@ in {
     enable = mkEnableOption "native Steam runtime";
 
     quirks = {
+      blackIsleStudios = mkEnableOption "fixes for games from Black Isle Studios";
       cryptOfTheNecrodancer = mkEnableOption ''fixes for "Crypt of the NecroDancer" issues'';
       mountAndBladeWarband = mkEnableOption ''fixes for "Mount & Blade: Warband" issues'';
     };
@@ -30,7 +31,8 @@ in {
       (steam.override {
         extraLibraries = _:
           with cfg.quirks;
-            optionals cryptOfTheNecrodancer [
+            optional blackIsleStudios openssl_1_0_0
+            ++ optionals cryptOfTheNecrodancer [
               (import (builtins.fetchTarball {
                 url = "https://github.com/NixOS/nixpkgs/archive/d1c3fea7ecbed758168787fe4e4a3157e52bc808.tar.gz";
                 sha256 = "0ykm15a690v8lcqf2j899za3j6hak1rm3xixdxsx33nz7n3swsyy";

Consider giving Nix/NixOS a try! <3