summaryrefslogtreecommitdiff
path: root/modules/nixos/games/steam.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/games/steam.nix')
-rw-r--r--modules/nixos/games/steam.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/modules/nixos/games/steam.nix b/modules/nixos/games/steam.nix
new file mode 100644
index 0000000..8dfa72c
--- /dev/null
+++ b/modules/nixos/games/steam.nix
@@ -0,0 +1,25 @@
+{
+ config,
+ lib,
+ pkgs,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.games.steam;
+in {
+ options.nixfiles.modules.games.steam.enable =
+ mkEnableOption "Steam runtime";
+
+ config = mkIf cfg.enable {
+ nixfiles.modules = {
+ common.nix.allowedUnfreePackages = ["steam" "steam-original"];
+
+ games = {
+ enable32BitSupport = true;
+ gamemode.enable = true;
+ };
+ };
+
+ hm.home.packages = with pkgs; [steam];
+ };
+}