summaryrefslogtreecommitdiff
path: root/modules/nixos/hydra.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/hydra.nix')
-rw-r--r--modules/nixos/hydra.nix54
1 files changed, 27 insertions, 27 deletions
diff --git a/modules/nixos/hydra.nix b/modules/nixos/hydra.nix
index ec3297c..85b89ab 100644
--- a/modules/nixos/hydra.nix
+++ b/modules/nixos/hydra.nix
@@ -1,11 +1,9 @@
-{
- config,
- lib,
- ...
-}:
-with lib; let
+{ config, lib, ... }:
+with lib;
+let
cfg = config.nixfiles.modules.hydra;
-in {
+in
+{
options.nixfiles.modules.hydra = {
enable = mkEnableOption "Hydra";
@@ -26,32 +24,34 @@ in {
nixfiles.modules = {
nginx = {
enable = true;
- upstreams.hydra.servers."127.0.0.1:${toString cfg.port}" = {};
+ upstreams.hydra.servers."127.0.0.1:${toString cfg.port}" = { };
virtualHosts.${cfg.domain}.locations."/".proxyPass = "http://hydra";
};
postgresql.enable = true;
};
- services = let
- db = "hydra";
- in {
- hydra = {
- enable = true;
- listenHost = "127.0.0.1";
- inherit (cfg) port;
- dbi = "dbi:Pg:dbname=${db};user=${db}";
- hydraURL = cfg.domain;
- };
+ services =
+ let
+ db = "hydra";
+ in
+ {
+ hydra = {
+ enable = true;
+ listenHost = "127.0.0.1";
+ inherit (cfg) port;
+ dbi = "dbi:Pg:dbname=${db};user=${db}";
+ hydraURL = cfg.domain;
+ };
- postgresql = {
- ensureDatabases = [db];
- ensureUsers = [
- {
- name = db;
- ensureDBOwnership = true;
- }
- ];
+ postgresql = {
+ ensureDatabases = [ db ];
+ ensureUsers = [
+ {
+ name = db;
+ ensureDBOwnership = true;
+ }
+ ];
+ };
};
- };
};
}