about summary refs log tree commit diff
path: root/modules/nixos/lidarr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/lidarr.nix')
-rw-r--r--modules/nixos/lidarr.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/nixos/lidarr.nix b/modules/nixos/lidarr.nix
new file mode 100644
index 0000000..f73f917
--- /dev/null
+++ b/modules/nixos/lidarr.nix
@@ -0,0 +1,28 @@
+{
+  config,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.lidarr;
+in {
+  options.nixfiles.modules.lidarr = {
+    enable = mkEnableOption "Lidarr";
+
+    domain = mkOption {
+      description = "Domain name sans protocol scheme.";
+      type = with types; str;
+      default = "lidarr.${config.networking.fqdn}";
+    };
+  };
+
+  config = mkIf cfg.enable {
+    nixfiles.modules.nginx = {
+      enable = true;
+      upstreams.lidarr.servers."127.0.0.1:8686" = {};
+      virtualHosts.${cfg.domain}.locations."/".proxyPass = "http://lidarr";
+    };
+
+    services.lidarr.enable = true;
+  };
+}

Consider giving Nix/NixOS a try! <3