summaryrefslogtreecommitdiff
path: root/modules/nixos/ntfy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/ntfy.nix')
-rw-r--r--modules/nixos/ntfy.nix9
1 files changed, 0 insertions, 9 deletions
diff --git a/modules/nixos/ntfy.nix b/modules/nixos/ntfy.nix
index edbe7e5..1682b7e 100644
--- a/modules/nixos/ntfy.nix
+++ b/modules/nixos/ntfy.nix
@@ -64,20 +64,11 @@ in {
settings = {
listen-http = "127.0.0.1:${toString cfg.port}";
base-url = "https://${cfg.domain}";
- cache-file = "/var/cache/ntfy/cache.db";
behind-proxy = true;
- attachment-cache-dir = "/var/cache/ntfy/attachments";
- auth-file = "/var/lib/ntfy/user.db";
enable-metrics = cfg.prometheus.enable;
metrics-listen-http = with cfg.prometheus;
optionalString cfg.prometheus.enable "${address}:${toString port}";
};
};
-
- systemd.tmpfiles.rules = with config.services.ntfy-sh; [
- "d /var/lib/ntfy 0700 ${user} ${group} - -"
- "d /var/cache/ntfy 0700 ${user} ${group} - -"
- "d /var/cache/ntfy/attachments 0700 ${user} ${group} - -"
- ];
};
}