summaryrefslogtreecommitdiff
path: root/modules/nixos/podman.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/podman.nix')
-rw-r--r--modules/nixos/podman.nix34
1 files changed, 29 insertions, 5 deletions
diff --git a/modules/nixos/podman.nix b/modules/nixos/podman.nix
index 1c5378b..cda8a4b 100644
--- a/modules/nixos/podman.nix
+++ b/modules/nixos/podman.nix
@@ -31,11 +31,35 @@ in {
my.extraGroups = ["podman"];
- hm.programs.bash = {
- shellAliases.p = "${pkgs.podman}/bin/podman";
- initExtra = mkAfter ''
- _complete_alias p __start_podman podman
- '';
+ hm = {
+ xdg.configFile = {
+ # This removes a really annoying registry search. 100% of the time I
+ # would need to look up stuff from the Docker and not Quay!
+ "containers/registries.conf".text = ''
+ [registries.search]
+ registries = ["docker.io"]
+ '';
+
+ # As for plain OverlayFS in Podman over ZFS[1]... I guess we are waiting
+ # for Podman to catch up now.
+ #
+ # [1]: https://github.com/openzfs/zfs/pull/14070#issuecomment-1309116666
+ "containers/storage.conf".text = optionalString config.boot.zfs.enabled ''
+ [storage]
+ driver = "overlay"
+
+ [storage.options]
+ mount_program = "${pkgs.fuse-overlayfs}/bin/fuse-overlayfs"
+ mountopt = "noatime,nodev,nosuid"
+ '';
+ };
+
+ programs.bash = {
+ shellAliases.p = "${pkgs.podman}/bin/podman";
+ initExtra = mkAfter ''
+ _complete_alias p __start_podman podman
+ '';
+ };
};
};
}