summaryrefslogtreecommitdiff
path: root/modules/nixos/profiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/profiles/default.nix')
-rw-r--r--modules/nixos/profiles/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/modules/nixos/profiles/default.nix b/modules/nixos/profiles/default.nix
new file mode 100644
index 0000000..d5ab838
--- /dev/null
+++ b/modules/nixos/profiles/default.nix
@@ -0,0 +1,33 @@
+{
+ config,
+ lib,
+ pkgs,
+ this,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.profiles.default;
+in {
+ imports = [
+ ./dev
+ ./headful.nix
+ ./headless.nix
+ ];
+
+ config = mkIf cfg.enable {
+ programs.less = {
+ enable = true;
+ envVariables.LESSHISTFILE = "-";
+ };
+
+ environment.systemPackages = with pkgs; [
+ cryptsetup
+ lshw
+ lsof
+ pciutils
+ psmisc
+ usbutils
+ util-linux
+ ];
+ };
+}