about summary refs log tree commit diff
path: root/modules/nixos/radicale.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/radicale.nix')
-rw-r--r--modules/nixos/radicale.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/modules/nixos/radicale.nix b/modules/nixos/radicale.nix
new file mode 100644
index 0000000..c903d39
--- /dev/null
+++ b/modules/nixos/radicale.nix
@@ -0,0 +1,52 @@
+{
+  config,
+  inputs,
+  lib,
+  ...
+}:
+with lib; let
+  cfg = config.nixfiles.modules.radicale;
+in {
+  options.nixfiles.modules.radicale = {
+    enable = mkEnableOption "Radicale";
+
+    domain = mkOption {
+      description = "Domain name sans protocol scheme.";
+      type = with types; str;
+      default = "radicale.${config.networking.domain}";
+    };
+  };
+
+  config = let
+    port = 5232;
+  in
+    mkIf cfg.enable {
+      secrets.radicale-htpasswd = {
+        file = "${inputs.self}/secrets/radicale-htpasswd";
+        owner = "radicale";
+        group = "radicale";
+      };
+
+      nixfiles.modules.nginx = {
+        enable = true;
+        upstreams.radicale.servers."127.0.0.1:${toString port}" = {};
+        virtualHosts.${cfg.domain} = {
+          locations."/".proxyPass = "http://radicale";
+          extraConfig = nginxInternalOnly;
+        };
+      };
+
+      services.radicale = {
+        enable = true;
+        settings = {
+          server.hosts = ["127.0.0.1:${toString port}"];
+          web.type = "none";
+          auth = {
+            type = "htpasswd";
+            htpasswd_filename = config.secrets.radicale-htpasswd.path;
+            htpasswd_encryption = "bcrypt";
+          };
+        };
+      };
+    };
+}

Consider giving Nix/NixOS a try! <3