about summary refs log tree commit diff
path: root/modules/nixos/soju.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/soju.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/nixos/soju.nix b/modules/nixos/soju.nix
index 569e218..b43fbdc 100644
--- a/modules/nixos/soju.nix
+++ b/modules/nixos/soju.nix
@@ -36,7 +36,7 @@ in {
     };
 
     prometheus = {
-      enable = mkEnableOption "Prometheus exporter." // {default = true;};
+      enable = mkEnableOption "Prometheus exporter" // {default = true;};
 
       port = mkOption {
         description = "Port.";
@@ -64,7 +64,7 @@ in {
         ensureUsers = [
           {
             name = db;
-            ensurePermissions."DATABASE \"${db}\"" = "ALL";
+            ensureDBOwnership = true;
           }
         ];
       };

Consider giving Nix/NixOS a try! <3