summaryrefslogtreecommitdiff
path: root/modules/nixos/sound.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/sound.nix')
-rw-r--r--modules/nixos/sound.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/nixos/sound.nix b/modules/nixos/sound.nix
new file mode 100644
index 0000000..ae35e44
--- /dev/null
+++ b/modules/nixos/sound.nix
@@ -0,0 +1,21 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.sound;
+in {
+ options.nixfiles.modules.sound.enable =
+ mkEnableOption "sound support";
+
+ config = mkIf cfg.enable {
+ services.pipewire = {
+ enable = true;
+
+ alsa.enable = false;
+ jack.enable = false;
+ pulse.enable = true;
+ };
+ };
+}