about summary refs log tree commit diff
path: root/modules/nixos/throttled.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/throttled.nix14
1 files changed, 1 insertions, 13 deletions
diff --git a/modules/nixos/throttled.nix b/modules/nixos/throttled.nix
index f182ee1..a84fd27 100644
--- a/modules/nixos/throttled.nix
+++ b/modules/nixos/throttled.nix
@@ -1,7 +1,6 @@
 {
   config,
   lib,
-  pkgs,
   ...
 }:
 with lib; let
@@ -10,8 +9,7 @@ in {
   options.nixfiles.modules.throttled.enable = mkEnableOption "Throttled";
 
   config = mkIf cfg.enable {
-    # Disable the module we are trying to "override".
-    services.throttled.enable = mkForce false;
+    services.throttled.enable = true;
 
     environment.etc."throttled.conf".text = ''
       [GENERAL]
@@ -105,15 +103,5 @@ in {
       # # CPU cache max current (A)
       # CACHE:
     '';
-
-    systemd.services.throttled = {
-      description = "Stop Intel throttling";
-      serviceConfig = {
-        Type = "simple";
-        ExecStart = "${pkgs.throttled}/opt/throttled/throttled.py";
-      };
-      environment.PYTHONUNBUFFERED = "1";
-      wantedBy = ["multi-user.target"];
-    };
   };
 }

Consider giving Nix/NixOS a try! <3