about summary refs log tree commit diff
path: root/modules/nixos/thunderbird.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/thunderbird.nix18
1 files changed, 13 insertions, 5 deletions
diff --git a/modules/nixos/thunderbird.nix b/modules/nixos/thunderbird.nix
index d8ce4ad..c534271 100644
--- a/modules/nixos/thunderbird.nix
+++ b/modules/nixos/thunderbird.nix
@@ -20,15 +20,23 @@ in {
         isDefault = true;
         withExternalGnupg = true;
         # https://github.com/HorlogeSkynet/thunderbird-user.js/blob/master/user.js
-        settings =
+        settings = with config.colors.withHashtag;
           config.hm.programs.firefox.profiles.default.settings
           // {
             "app.donation.eoy.version.viewed" = 999;
-            "browser.display.background_color" = config.colors.withHashtag.base00;
-            "browser.display.background_color.dark" = config.colors.withHashtag.base00;
+            "browser.display.background_color" = base00;
+            "browser.display.background_color.dark" = base00;
             "browser.display.document_color_use" = 2;
-            "browser.display.foreground_color" = config.colors.withHashtag.base07;
-            "browser.display.foreground_color.dark" = config.colors.withHashtag.base07;
+            "browser.display.foreground_color" = base05;
+            "browser.display.foreground_color.dark" = base05;
+            "browser.display.use_system_colors" = false;
+            "editor.background_color" = base00;
+            "editor.editor.active_link_color" = base16;
+            "editor.followed_link_color" = base0E;
+            "editor.link_color" = base0D;
+            "editor.text_color" = base05;
+            "editor.use_custom_colors" = true;
+            "extensions.activeThemeID" = "default-theme@mozilla.org";
             "javascript.enabled" = false;
             "mail.chat.enabled" = false;
             "mail.cloud_files.enabled" = false;

Consider giving Nix/NixOS a try! <3