summaryrefslogtreecommitdiff
path: root/modules/nixos/thunderbird.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/thunderbird.nix')
-rw-r--r--modules/nixos/thunderbird.nix88
1 files changed, 65 insertions, 23 deletions
diff --git a/modules/nixos/thunderbird.nix b/modules/nixos/thunderbird.nix
index ff0d823..e598e21 100644
--- a/modules/nixos/thunderbird.nix
+++ b/modules/nixos/thunderbird.nix
@@ -19,29 +19,71 @@ in {
profiles.default = {
isDefault = true;
withExternalGnupg = true;
- };
- settings = {
- "app.update.auto" = false;
- "browser.display.document_color_use" = 2;
- "browser.display.use_system_colors" = true;
- "browser.search.region" = "US";
- "browser.search.update" = false;
- "datareporting.healthreport.uploadEnabled" = false;
- "full-screen-api.warning.delay" = 0;
- "full-screen-api.warning.timeout" = 0;
- "general.autoScroll" = true;
- "general.smoothScroll" = true;
- "mail.default_send_format" = 0;
- "mail.tabs.drawInTitlebar" = 1;
- "mailnews.start_page.url" = "about:blank";
- "media.autoplay.blocking_policy" = 2;
- "media.autoplay.default" = 5;
- "media.autoplay.enabled" = false;
- "media.hardwaremediakeys.enabled" = false;
- "network.cookie.cookieBehavior" = 2;
- "places.history.enabled" = false;
- "reader.parse-on-load.enabled" = false;
- "toolkit.legacyUserProfileCustomizations.stylesheets" = true;
+ # https://github.com/HorlogeSkynet/thunderbird-user.js/blob/master/user.js
+ settings =
+ config.hm.programs.firefox.profiles.default.settings
+ // {
+ "app.donation.eoy.version.viewed" = 999;
+ "browser.display.document_color_use" = 2;
+ "browser.display.use_system_colors" = true;
+ "browser.fixup.alternate.enabled" = false;
+ "calendar.extract.service.enabled" = false;
+ "calendar.timezone.local" = "UTC";
+ "extensions.cardbook.useOnlyEmail" = true;
+ "javascript.enabled" = false;
+ "mail.chat.enabled" = false;
+ "mail.cloud_files.enabled" = false;
+ "mail.collect_email_address_outgoing" = false;
+ "mail.compose.add_link_preview" = false;
+ "mail.compose.big_attachments.notify" = true;
+ "mail.compose.big_attachments.threshold_kb" = 9220;
+ "mail.compose.warn_public_recipients.aggressive" = true;
+ "mail.default_send_format" = 1;
+ "mail.html_compose" = false;
+ "mail.html_sanitize.drop_conditional_css" = true;
+ "mail.identity.default.compose_html" = false;
+ "mail.inline_attachments" = false;
+ "mail.instrumentation.askUser" = false;
+ "mail.instrumentation.postUrl" = "";
+ "mail.instrumentation.userOptedIn" = false;
+ "mail.phishing.detection.disallow_form_actions" = true;
+ "mail.phishing.detection.enabled" = true;
+ "mail.phishing.detection.ipaddresses" = true;
+ "mail.phishing.detection.mismatched_hosts" = true;
+ "mail.provider.enabled" = false;
+ "mail.rights.override" = true;
+ "mail.sanitize_date_header" = true;
+ "mail.showCondensedAddresses" = false;
+ "mail.suppress_content_language" = true;
+ "mailnews.auto_config.addons_url" = "";
+ "mailnews.auto_config.fetchFromExchange.enabled" = false;
+ "mailnews.auto_config.fetchFromISP.enabled" = false;
+ "mailnews.auto_config.fetchFromISP.sendEmailAddress" = false;
+ "mailnews.auto_config.guess.enabled" = false;
+ "mailnews.auto_config.guess.requireGoodCert" = true;
+ "mailnews.auto_config.guess.sslOnly" = true;
+ "mailnews.auto_config_url" = "";
+ "mailnews.display.date_senders_timezone" = false;
+ "mailnews.display.disallow_mime_handlers" = 3;
+ "mailnews.display.html_as" = 3;
+ "mailnews.display.original_date" = false;
+ "mailnews.display.prefer_plaintext" = false;
+ "mailnews.headers.sendUserAgent" = true;
+ "mailnews.headers.showSender" = true;
+ "mailnews.headers.showUserAgent" = false;
+ "mailnews.headers.useMinimalUserAgent" = true;
+ "mailnews.message_display.disable_remote_image" = true;
+ "mailnews.reply_header_authorwrotesingle" = "#1 wrote:";
+ "mailnews.reply_header_type" = 1;
+ "mailnews.start_page.enabled" = false;
+ "mailnews.start_page.url" = "about:blank";
+ "media.mediasource.enabled" = false;
+ "permissions.default.image" = 2;
+ "places.history.enabled" = false;
+ "pref.privacy.disable_button.cookie_exceptions" = false;
+ "pref.privacy.disable_button.view_cookies" = false;
+ "pref.privacy.disable_button.view_passwords" = false;
+ };
};
};
};