summaryrefslogtreecommitdiff
path: root/modules/nixos/wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/wayland.nix')
-rw-r--r--modules/nixos/wayland.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/nixos/wayland.nix b/modules/nixos/wayland.nix
new file mode 100644
index 0000000..5068c25
--- /dev/null
+++ b/modules/nixos/wayland.nix
@@ -0,0 +1,19 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.wayland;
+in {
+ options.nixfiles.modules.wayland.enable = mkEnableOption "Wayland";
+
+ config = mkIf cfg.enable {
+ assertions = [
+ {
+ assertion = !config.nixfiles.modules.x11.enable;
+ message = "Pick only one!";
+ }
+ ];
+ };
+}