about summary refs log tree commit diff
path: root/modules/nixos/x11.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/nixos/x11.nix44
1 files changed, 9 insertions, 35 deletions
diff --git a/modules/nixos/x11.nix b/modules/nixos/x11.nix
index b629aeb..bd35d87 100644
--- a/modules/nixos/x11.nix
+++ b/modules/nixos/x11.nix
@@ -25,40 +25,14 @@ in {
         XCOMPOSECACHE = "${config.dirs.cache}/libx11/compose";
       };
 
-      xresources.properties =
-        (let
-          font = with config.fontScheme.monospaceFont; "${family}:style=${style}:size=${toString size}";
-        in {
-          "*.font" = font;
-
-          "Xft.antialias" = mkDefault 1;
-          "Xft.autohint" = mkDefault 0;
-          "Xft.hinting" = mkDefault 1;
-          "Xft.hintstyle" = mkDefault "hintslight";
-          "Xft.lcdfilter" = mkDefault "lcddefault";
-          "Xft.rgba" = mkDefault "rgb";
-        })
-        // (with config.colourScheme; {
-          "*.color0" = black;
-          "*.color8" = brightBlack;
-          "*.color1" = red;
-          "*.color9" = brightRed;
-          "*.color2" = green;
-          "*.color10" = brightGreen;
-          "*.color3" = yellow;
-          "*.color11" = brightYellow;
-          "*.color4" = blue;
-          "*.color12" = brightBlue;
-          "*.color5" = magenta;
-          "*.color13" = brightMagenta;
-          "*.color6" = cyan;
-          "*.color14" = brightCyan;
-          "*.color7" = white;
-          "*.color15" = brightWhite;
-
-          "*.background" = background;
-          "*.foreground" = foreground;
-        });
+      xresources.properties = {
+        "Xft.antialias" = mkDefault 1;
+        "Xft.autohint" = mkDefault 0;
+        "Xft.hinting" = mkDefault 1;
+        "Xft.hintstyle" = mkDefault "hintslight";
+        "Xft.lcdfilter" = mkDefault "lcddefault";
+        "Xft.rgba" = mkDefault "rgb";
+      };
 
       services.xsettingsd = {
         enable = true;
@@ -87,7 +61,7 @@ in {
       tty = mkDefault 1;
 
       autoRepeatDelay = 200;
-      autoRepeatInterval = 25;
+      autoRepeatInterval = 50;
 
       libinput.enable = true;
 

Consider giving Nix/NixOS a try! <3