summaryrefslogtreecommitdiff
path: root/modules/nixos/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nixos/zathura.nix')
-rw-r--r--modules/nixos/zathura.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/modules/nixos/zathura.nix b/modules/nixos/zathura.nix
new file mode 100644
index 0000000..e7d1415
--- /dev/null
+++ b/modules/nixos/zathura.nix
@@ -0,0 +1,15 @@
+{
+ config,
+ lib,
+ ...
+}:
+with lib; let
+ cfg = config.nixfiles.modules.zathura;
+in {
+ config = mkIf cfg.enable {
+ nixfiles.modules.common.xdg.defaultApplications."org.pwmt.zathura" = [
+ "application/pdf"
+ "application/epub+zip"
+ ];
+ };
+}