about summary refs log tree commit diff
path: root/modules/nsd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nsd.nix')
-rw-r--r--modules/nsd.nix33
1 files changed, 30 insertions, 3 deletions
diff --git a/modules/nsd.nix b/modules/nsd.nix
index 82dc16a..df97d06 100644
--- a/modules/nsd.nix
+++ b/modules/nsd.nix
@@ -85,6 +85,24 @@ in
                   selector = "mail";
                   p = dkimKey;
                 };
+                SRV = [
+                  {
+                    service = "submissions";
+                    proto = "tcp";
+                    priority = 5;
+                    weight = 0;
+                    port = 465;
+                    target = "${lib.my.domain.shire}.";
+                  }
+                  {
+                    service = "imaps";
+                    proto = "tcp";
+                    priority = 5;
+                    weight = 0;
+                    port = 993;
+                    target = "${lib.my.domain.shire}.";
+                  }
+                ];
                 subdomains._mta-sts.TXT = [ "v=STSv1; id=20230506134541Z" ];
               };
 
@@ -103,7 +121,7 @@ in
                       SOA = {
                         nameServer = "${cfg.fqdn}.";
                         adminEmail = "hostmaster@${lib.my.domain.shire}";
-                        serial = 2025020201; # Don't forget to bump the revision!
+                        serial = 2025031201; # Don't forget to bump the revision!
                       };
 
                       NS = with lib.my.domain; [
@@ -147,15 +165,14 @@ in
                     ns1 = manwe;
                     # ns2 = varda;
 
-                    alertmanager = manwe;
                     bitwarden = manwe;
                     git = manwe;
                     grafana = manwe;
                     irc = manwe;
                     loki = manwe;
+                    mimir = manwe;
                     ntfy = manwe;
                     plausible = manwe;
-                    prometheus = manwe;
                     radicale = manwe;
                     rss-bridge = manwe;
                     uptime = manwe;
@@ -166,6 +183,16 @@ in
                     lidarr = yavanna;
                     prowlarr = yavanna;
                   };
+                  SRV = [
+                    {
+                      service = "mumble";
+                      proto = "tcp";
+                      priority = 5;
+                      weight = 0;
+                      port = 64738;
+                      target = "${lib.my.domain.shire}.";
+                    }
+                  ];
                 }
               ];
             })

Consider giving Nix/NixOS a try! <3