about summary refs log tree commit diff
path: root/modules/ntfy.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/ntfy.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/ntfy.nix b/modules/ntfy.nix
index 5739855..e3de72e 100644
--- a/modules/ntfy.nix
+++ b/modules/ntfy.nix
@@ -1,5 +1,6 @@
 {
   config,
+  inputs,
   lib,
   libNginx,
   this,
@@ -76,5 +77,14 @@ in
           optionalString cfg.prometheus.enable "${address}:${toString port}";
       };
     };
+
+    topology = with cfg; {
+      nodes.${this.hostname}.services.ntfy = {
+        name = "ntfy";
+        icon = "${inputs.homelab-svg-assets}/assets/ntfy.svg";
+        info = domain;
+        details.listen.text = config.services.ntfy-sh.settings.listen-http;
+      };
+    };
   };
 }

Consider giving Nix/NixOS a try! <3