summaryrefslogtreecommitdiff
path: root/modules/nullmailer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nullmailer.nix')
-rw-r--r--modules/nullmailer.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/nullmailer.nix b/modules/nullmailer.nix
new file mode 100644
index 0000000..9f7b4ac
--- /dev/null
+++ b/modules/nullmailer.nix
@@ -0,0 +1,30 @@
+{
+ config,
+ inputs,
+ lib,
+ ...
+}:
+with lib;
+let
+ cfg = config.nixfiles.modules.nullmailer;
+in
+{
+ options.nixfiles.modules.nullmailer.enable = mkEnableOption "Nullmailer";
+
+ config = mkIf cfg.enable {
+ # No use in enabling it other than having a retry queue.
+ # ark.directories = ["/var/spool/nullmailer"];
+
+ secrets.nullmailer-remotes = with config.services.nullmailer; {
+ file = "${inputs.self}/secrets/nullmailer-remotes";
+ owner = user;
+ inherit group;
+ };
+
+ services.nullmailer = {
+ enable = true;
+ remotesFile = config.secrets.nullmailer-remotes.path;
+ config.me = config.networking.domain;
+ };
+ };
+}