summaryrefslogtreecommitdiff
path: root/modules/plausible.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/plausible.nix')
-rw-r--r--modules/plausible.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/plausible.nix b/modules/plausible.nix
index d63e3ab..c5b66c3 100644
--- a/modules/plausible.nix
+++ b/modules/plausible.nix
@@ -2,6 +2,7 @@
config,
inputs,
lib,
+ this,
...
}:
with lib;
@@ -125,5 +126,14 @@ in
];
requires = after;
};
+
+ topology = with cfg; {
+ nodes.${this.hostname}.services.plausible = {
+ name = "Plausible";
+ icon = "${inputs.homelab-svg-assets}/assets/plausible.svg";
+ info = domain;
+ details.listen.text = "${config.services.plausible.server.listenAddress}:${toString port}";
+ };
+ };
};
}