about summary refs log tree commit diff
path: root/modules/profiles/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/profiles/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/profiles/default.nix b/modules/profiles/default.nix
index 34093d0..cbfb665 100644
--- a/modules/profiles/default.nix
+++ b/modules/profiles/default.nix
@@ -5,20 +5,19 @@
   this,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.profiles.default;
 in
 {
-  imports = attrValues (modulesIn ./.);
+  imports = lib.modulesIn ./. |> lib.attrValues;
 
   options.nixfiles.modules.profiles.default.enable =
-    mkEnableOption "The most default profile of them all."
+    lib.mkEnableOption "The most default profile of them all."
     // {
       default = true;
     };
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     assertions = [
       {
         assertion = !(with this; isHeadless && isHeadful);

Consider giving Nix/NixOS a try! <3