about summary refs log tree commit diff
path: root/modules/profiles/dev/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/profiles/dev/default.nix')
-rw-r--r--modules/profiles/dev/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/modules/profiles/dev/default.nix b/modules/profiles/dev/default.nix
index a6cc61d..89ed7a3 100644
--- a/modules/profiles/dev/default.nix
+++ b/modules/profiles/dev/default.nix
@@ -4,17 +4,16 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.profiles.dev;
 in
 {
-  imports = attrValues (modulesIn ./.);
+  imports = lib.modulesIn ./. |> lib.attrValues;
 
   options.nixfiles.modules.profiles.dev.enable =
-    mkEnableOption "Catch-all profile for stuff related to software development and etc.";
+    lib.mkEnableOption "Catch-all profile for stuff related to software development and etc.";
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     nixfiles.modules = {
       common.nix.allowedUnfreePackages = [
         "terraform" # source-available

Consider giving Nix/NixOS a try! <3