about summary refs log tree commit diff
path: root/modules/profiles/dev/sql.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/profiles/dev/sql.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/modules/profiles/dev/sql.nix b/modules/profiles/dev/sql.nix
index c2d4894..cbab14a 100644
--- a/modules/profiles/dev/sql.nix
+++ b/modules/profiles/dev/sql.nix
@@ -4,18 +4,17 @@
   pkgs,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.profiles.dev.sql;
 in
 {
   options.nixfiles.modules.profiles.dev.sql.enable =
-    mkEnableOption "SQL stuff and database management tools"
+    lib.mkEnableOption "SQL stuff and database management tools"
     // {
       default = config.nixfiles.modules.profiles.dev.enable;
     };
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     hm = {
       home.packages = with pkgs; [
         pgcli
@@ -63,15 +62,15 @@ in
             { name, custom }:
             {
               "${name}/config" = {
-                text = generators.toINI { } {
+                text = lib.generators.toINI { } {
                   main = mainSection // custom;
-                  colors = mapAttrs (_: v: "'${v}'") colorsSection;
+                  colors = lib.mapAttrs (_: v: "'${v}'") colorsSection;
                 };
               };
             };
         in
         {
-          configFile = mkMerge (
+          configFile = lib.mkMerge (
             map mkCliConfig [
               {
                 name = "pgcli";

Consider giving Nix/NixOS a try! <3