about summary refs log tree commit diff
path: root/modules/profiles/email.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/profiles/email.nix26
1 files changed, 13 insertions, 13 deletions
diff --git a/modules/profiles/email.nix b/modules/profiles/email.nix
index 4c8d6eb..5f142dc 100644
--- a/modules/profiles/email.nix
+++ b/modules/profiles/email.nix
@@ -5,16 +5,15 @@
   this,
   ...
 }:
-with lib;
 let
   cfg = config.nixfiles.modules.profiles.email;
 in
 {
-  options.nixfiles.modules.profiles.email.enable = mkEnableOption "Local Email management" // {
+  options.nixfiles.modules.profiles.email.enable = lib.mkEnableOption "Local Email management" // {
     default = this.isHeadful;
   };
 
-  config = mkIf cfg.enable {
+  config = lib.mkIf cfg.enable {
     nixfiles.modules.gnupg.enable = true;
 
     hm = {
@@ -25,7 +24,7 @@ in
           let
             mkAccount =
               attrs:
-              mkMerge [
+              lib.mkMerge [
                 {
                   mbsync = {
                     enable = true;
@@ -52,15 +51,15 @@ in
                 line ? 0,
               }:
               assert (builtins.isInt line);
-              concatStringsSep " " (
+              lib.concatStringsSep " " (
                 [
-                  (getExe config.hm.programs.password-store.package)
+                  (lib.getExe config.hm.programs.password-store.package)
                   "show"
                   path
                 ]
-                ++ optionals (line > 0) [
+                ++ lib.optionals (line > 0) [
                   "|"
-                  (getExe pkgs.gnused)
+                  (lib.getExe pkgs.gnused)
                   "-e"
                   "'${toString line}!d'"
                 ]
@@ -68,22 +67,23 @@ in
           in
           {
             shire = mkAccount rec {
-              address = my.email;
+              address = lib.my.email;
               aliases = [
                 address
                 "frodo@rohan.net"
                 "azahi@shire.net"
               ];
-              realName = my.fullname;
+              realName = lib.my.fullname;
               signature = {
                 showSignature = "append";
                 text = ''
-                  Please consider using plain text when replying!
-                  ~    https://useplaintext.email/#etiquette    ~
+                  Firstname Lastname     | Азат Багавиев
+                  frodo@gondor.net | frodo@rohan.net
+                          https://azahi.cc/
                 '';
               };
               gpg = {
-                inherit (my.pgp) key;
+                inherit (lib.my.pgp) key;
                 signByDefault = false;
                 encryptByDefault = false;
               };

Consider giving Nix/NixOS a try! <3