about summary refs log tree commit diff
path: root/modules/profiles/email.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/profiles/email.nix21
1 files changed, 15 insertions, 6 deletions
diff --git a/modules/profiles/email.nix b/modules/profiles/email.nix
index b2ef02f..5dd4712 100644
--- a/modules/profiles/email.nix
+++ b/modules/profiles/email.nix
@@ -75,6 +75,15 @@ in
                 "azahi@shire.net"
               ];
               realName = my.fullname;
+              signature = {
+                showSignature = "append";
+                text = ''
+                  Firstname Lastname | Firstname Lastname | https://azahi.cc/
+
+                  Please consider using plain text when replying!
+                    >> https://useplaintext.email/#etiquette <<
+                '';
+              };
               gpg = {
                 inherit (my.pgp) key;
                 signByDefault = false;
@@ -97,18 +106,18 @@ in
               passwordCommand = getPassword { path = "email/shire.net/azahi"; };
             };
 
-            yahoo = mkAccount rec {
-              address = "admin@yahoo.com";
+            yandex = mkAccount rec {
+              address = "username@ya.ru";
               aliases = [
                 address
-                "admin@yahoo.com"
+                "username@yandex.ru"
               ];
               realName = "Firstname Lastname";
 
-              flavor = "yahoo.com";
-              userName = "admin@yahoo.com";
+              flavor = "yandex.com";
+              userName = "username@yandex.ru";
               passwordCommand = getPassword {
-                path = "email/yahoo.com/admin";
+                path = "email/yandex.ru/username";
                 line = 2;
               };
             };

Consider giving Nix/NixOS a try! <3