about summary refs log tree commit diff
path: root/modules/prometheus.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/prometheus.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/prometheus.nix b/modules/prometheus.nix
index 9f28cd5..673f288 100644
--- a/modules/prometheus.nix
+++ b/modules/prometheus.nix
@@ -1,7 +1,9 @@
 {
   config,
+  inputs,
   lib,
   libNginx,
+  this,
   ...
 }:
 with lib;
@@ -49,5 +51,14 @@ in
         "--storage.tsdb.wal-compression"
       ];
     };
+
+    topology = with cfg; {
+      nodes.${this.hostname}.services.prometheus = {
+        name = "Prometheus";
+        icon = "${inputs.homelab-svg-assets}/assets/prometheus.svg";
+        info = domain;
+        details.listen.text = "127.0.0.1:${toString port}";
+      };
+    };
   };
 }

Consider giving Nix/NixOS a try! <3