summaryrefslogtreecommitdiff
path: root/modules/syncthing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/syncthing.nix')
-rw-r--r--modules/syncthing.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/modules/syncthing.nix b/modules/syncthing.nix
index 74d4afe..e261a12 100644
--- a/modules/syncthing.nix
+++ b/modules/syncthing.nix
@@ -62,17 +62,18 @@ in
settings = {
options = {
+ announceLANAddresses = false;
autoUpgradeIntervalH = 0;
crashReportingEnabled = false;
globalAnnounceEnabled = false;
relaysEnabled = false;
- setLowPriority = this.isHeadless;
+ setLowPriority = this.isHeadful;
stunKeepaliveStartS = 0;
urAccepted = -1;
};
gui = {
- insecureAdminAccess = true;
+ insecureAdminAccess = this.isHeadless;
insecureSkipHostcheck = this.isHeadless;
};
@@ -80,9 +81,12 @@ in
name: attr:
mkIf (attr.syncthing.id != null && hasAttr "wireguard" attr) {
inherit (attr.syncthing) id;
- compression = "metadata";
+ compression = "always";
introducer = false;
- address = "tcp://${name}.${config.networking.domain}:22000";
+ addresses = [
+ "quic://${name}.${config.networking.domain}:22000"
+ "tcp://${name}.${config.networking.domain}:22000"
+ ];
autoAcceptFolders = true;
untrusted = false;
}