about summary refs log tree commit diff
path: root/modules/vscode.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/vscode.nix15
1 files changed, 10 insertions, 5 deletions
diff --git a/modules/vscode.nix b/modules/vscode.nix
index 393b32f..3b0c3e1 100644
--- a/modules/vscode.nix
+++ b/modules/vscode.nix
@@ -51,9 +51,8 @@ in
               editorconfig.editorconfig
               efoerster.texlab
               github.vscode-pull-request-github
-              gitlab.gitlab-workflow
               golang.go
-              # graphql.vscode-graphql
+              graphql.vscode-graphql
               graphql.vscode-graphql-execution
               graphql.vscode-graphql-syntax
               hashicorp.hcl
@@ -75,12 +74,16 @@ in
               streetsidesoftware.code-spell-checker-russian
               streetsidesoftware.code-spell-checker-scientific-terms
               tamasfe.even-better-toml
-              # task.vscode-task
-              # vscode-org-mode.org-mode
+              task.vscode-task
+              vscode-org-mode.org-mode
             ]
             ++ optional cfg.vim.enable vscodevim.vim;
 
           userSettings = {
+            # Something tries to write this every startup. I can't be arsed to
+            # figure out what, so I'll leave this like this.
+            "accessibility.signals.terminalBell".sound = "on";
+
             editor = {
               codeLens = false;
               cursorStyle = "block";
@@ -184,8 +187,10 @@ in
             };
 
             nix = {
+              formatterPath = getExe pkgs.nixfmt;
               enableLanguageServer = true;
-              serverPath = getExe pkgs.nil;
+              serverPath = getExe pkgs.nixd;
+              serverSettings.nixd.formatting.command = getExe pkgs.nixfmt;
             };
 
             python = with pkgs.python311Packages; {

Consider giving Nix/NixOS a try! <3