about summary refs log tree commit diff
path: root/modules/wireguard-ng.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--modules/wireguard-ng.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/modules/wireguard-ng.nix b/modules/wireguard-ng.nix
index 5374a71..1d291c9 100644
--- a/modules/wireguard-ng.nix
+++ b/modules/wireguard-ng.nix
@@ -128,13 +128,6 @@ in
           "${inputs.self}/secrets/wireguard-private-key-${this.hostname}";
 
         networking.firewall.trustedInterfaces = [ cfg.interface ];
-
-        topology = with cfg; {
-          nodes.${this.hostname}.interfaces.${interface} = {
-            network = interface;
-            icon = "interfaces.wireguard";
-          };
-        };
       })
       (mkIf cfg.client.enable {
         networking.wg-quick.interfaces.${cfg.interface} = mkMerge [
@@ -233,23 +226,6 @@ in
           withRemoteIp = true;
           port = 9586;
         };
-
-        topology = with cfg; {
-          networks = {
-            ${interface} = {
-              name = interface;
-              cidrv4 = ipv4.subnet;
-              cidrv6 = ipv6.subnet;
-              icon = "interfaces.wireguard";
-            };
-          };
-
-          nodes.${this.hostname}.interfaces.${interface}.physicalConnections =
-            mapAttrsToList (name: _: config.lib.topology.mkConnection name interface)
-              (
-                filterAttrs (n: v: !v.isOther && n != this.hostname && hasAttr "wireguard-ng" v) my.configurations
-              );
-        };
       })
     ];
 }

Consider giving Nix/NixOS a try! <3