summaryrefslogtreecommitdiff
path: root/modules/xmonad.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/xmonad.nix')
-rw-r--r--modules/xmonad.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/modules/xmonad.nix b/modules/xmonad.nix
deleted file mode 100644
index 7b49f52..0000000
--- a/modules/xmonad.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib;
-let
- cfg = config.nixfiles.modules.xmonad;
-in
-{
- options.nixfiles.modules.xmonad.enable = mkEnableOption "XMonad";
-
- config = mkIf cfg.enable {
- nixfiles.modules.x11.enable = true;
-
- hm = {
- xsession = {
- enable = true;
-
- scriptPath = ".xinitrc";
-
- windowManager.command = getExe' pkgs.xmonad-ng "xmonad-ng";
- };
- };
-
- services.xserver.displayManager.startx.enable = true;
-
- nixpkgs.overlays = [ inputs.xmonad-ng.overlays.default ];
- };
-}