summaryrefslogtreecommitdiff
path: root/modules/zathura.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/zathura.nix')
-rw-r--r--modules/zathura.nix85
1 files changed, 85 insertions, 0 deletions
diff --git a/modules/zathura.nix b/modules/zathura.nix
new file mode 100644
index 0000000..cef841c
--- /dev/null
+++ b/modules/zathura.nix
@@ -0,0 +1,85 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.zathura;
+in
+{
+ options.nixfiles.modules.zathura.enable = mkEnableOption "Zathura PDF reader";
+
+ config = mkIf cfg.enable {
+ nixfiles.modules.common.xdg.defaultApplications."org.pwmt.zathura" = [
+ "application/pdf"
+ "application/epub+zip"
+ ];
+
+ hm.programs.zathura = {
+ enable = true;
+
+ options = {
+ recolor = true;
+ recolor-keephue = false;
+ recolor-reverse-video = false;
+
+ highlight-transparency = "0.3";
+
+ n-completion-items = 10;
+
+ guioptions = "";
+
+ statusbar-basename = true;
+ statusbar-home-tilde = true;
+
+ statusbar-h-padding = 0;
+ statusbar-v-padding = 0;
+
+ window-height = 800;
+ window-width = 600;
+
+ window-icon = "";
+
+ abort-clear-search = true;
+
+ incremental-search = true;
+
+ adjust-open = "best-fit";
+
+ advance-pages-per-row = false;
+
+ database = "sqlite";
+
+ dbus-service = false;
+
+ page-padding = 0;
+
+ pages-per-row = 1;
+
+ render-loading = false;
+
+ show-directories = true;
+ show-hidden = true;
+ show-recent = 10;
+
+ link-zoom = true;
+ link-hadjust = true;
+
+ window-title-basename = true;
+ window-title-home-tilde = true;
+ window-title-page = true;
+
+ zoom-center = false;
+ zoom-max = 1000;
+ zoom-min = 10;
+ zoom-step = 10;
+
+ scroll-hstep = -1;
+ scroll-step = 40;
+ scroll-full-overlap = 0;
+ scroll-wrap = true;
+ scroll-page-aware = false;
+
+ selection-clipboard = "clipboard";
+ selection-notification = false;
+ };
+ };
+ };
+}