about summary refs log tree commit diff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nixosConfigurations/eonwe/default.nix25
1 files changed, 23 insertions, 2 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index f66478d..3476e6d 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -21,7 +21,7 @@ with lib; {
     };
     android.enable = true;
     bluetooth.enable = true;
-    discord.enable = true;
+    beets.enable = true;
     libvirtd.enable = true;
     qutebrowser.enable = true;
     mpd.enable = true;
@@ -31,6 +31,8 @@ with lib; {
     home.packages = with pkgs; [obs-studio];
 
     programs = {
+      beets.settings.directory = mkForce "/mnt/udata/music";
+
       # NOTE This produces very poor performance even though RX 6750 XT should
       # handle VA-API hardware decoding for all major formats (including AV1) just
       # fine.
@@ -43,6 +45,25 @@ with lib; {
         profile = "gpu-hq";
       };
     };
+
+    services.mpd.musicDirectory = mkForce "/mnt/udata/music";
+  };
+
+  services = {
+    smartd = {
+      enable = true;
+      notifications = {
+        test = true;
+        mail = {
+          # TODO
+        };
+      };
+    };
+
+    # nullmailer = {
+    #   enable = true;
+    #   me = config.networking.fqdn;
+    # };
   };
 
   # Usually stuff that is going to be compiled on this machine is going to have
@@ -74,7 +95,7 @@ with lib; {
     # The boot drive is Samsung SSD 980 PRO 2TB.
     initrd.kernelModules = ["nvme"];
 
-    zfs.extraPools = ["vdata"];
+    zfs.extraPools = ["udata" "vdata"];
   };
 
   # Filesystem creation:

Consider giving Nix/NixOS a try! <3