about summary refs log tree commit diff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nixosConfigurations/eonwe/default.nix92
1 files changed, 50 insertions, 42 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index 8164cd4..94f70ef 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -4,10 +4,9 @@
   pkgs,
   ...
 }:
-with lib; {
-  imports = [
-    ./hidden.nix
-  ];
+with lib;
+{
+  imports = [ ./hidden.nix ];
 
   nixfiles.modules = {
     ark.enable = true;
@@ -44,6 +43,7 @@ with lib; {
       openmw
       openttd
       qbittorrent
+      qolibri
       qzdl
       radeontop
       vcmi
@@ -57,38 +57,40 @@ with lib; {
       beets.settings.directory = mkForce "/mnt/udata/music";
 
       mpv = {
-        profiles = let
-          mapShaders = shaders: map (args: toString (pkgs.fetchurl args)) shaders;
-          cfl-prediction = mapShaders [
-            {
-              url = "https://raw.githubusercontent.com/Artoriuz/glsl-chroma-from-luma-prediction/471c65dd3915d39e7ef69957ab63e006125fbb88/CfL_Prediction.glsl";
-              sha256 = "sha256-Mgb1KqF1EPPzR3SCVr9S4XzVmZkYEEFIHSp59RZ9wq8=";
-            }
-          ];
-          ravu-lite-ar-r4 = mapShaders [
-            {
-              url = "https://raw.githubusercontent.com/bjin/mpv-prescalers/b3f0a59d68f33b7162051ea5970a5169558f0ea2/compute/ravu-lite-ar-r4.hook";
-              sha256 = "sha256-gyBAv/Sf75CobVUugeTOhy54B9z8iIoJSJgnLopfMsY=";
-            }
-          ];
-          ssimdownscaler = mapShaders [
-            {
-              url = "https://gist.githubusercontent.com/igv/36508af3ffc84410fe39761d6969be10/raw/575d13567bbe3caa778310bd3b2a4c516c445039/SSimDownscaler.glsl";
-              sha256 = "sha256-AEq2wv/Nxo9g6Y5e4I9aIin0plTcMqBG43FuOxbnR1w=";
-            }
-          ];
-        in {
-          # TODO Profile conditionals on width are not working.
-          "qhd-downscale" = {
-            dscale = "lanczos";
-            linear-downscaling = false;
-            glsl-shaders-append = ssimdownscaler;
-          };
-
-          "qhd-upscale" = {
-            glsl-shaders-append = cfl-prediction ++ ravu-lite-ar-r4;
+        profiles =
+          let
+            mapShaders = shaders: map (args: toString (pkgs.fetchurl args)) shaders;
+            cfl-prediction = mapShaders [
+              {
+                url = "https://raw.githubusercontent.com/Artoriuz/glsl-chroma-from-luma-prediction/471c65dd3915d39e7ef69957ab63e006125fbb88/CfL_Prediction.glsl";
+                sha256 = "sha256-Mgb1KqF1EPPzR3SCVr9S4XzVmZkYEEFIHSp59RZ9wq8=";
+              }
+            ];
+            ravu-lite-ar-r4 = mapShaders [
+              {
+                url = "https://raw.githubusercontent.com/bjin/mpv-prescalers/b3f0a59d68f33b7162051ea5970a5169558f0ea2/compute/ravu-lite-ar-r4.hook";
+                sha256 = "sha256-gyBAv/Sf75CobVUugeTOhy54B9z8iIoJSJgnLopfMsY=";
+              }
+            ];
+            ssimdownscaler = mapShaders [
+              {
+                url = "https://gist.githubusercontent.com/igv/36508af3ffc84410fe39761d6969be10/raw/575d13567bbe3caa778310bd3b2a4c516c445039/SSimDownscaler.glsl";
+                sha256 = "sha256-AEq2wv/Nxo9g6Y5e4I9aIin0plTcMqBG43FuOxbnR1w=";
+              }
+            ];
+          in
+          {
+            # TODO Profile conditionals on width are not working.
+            "qhd-downscale" = {
+              dscale = "lanczos";
+              linear-downscaling = false;
+              glsl-shaders-append = ssimdownscaler;
+            };
+
+            "qhd-upscale" = {
+              glsl-shaders-append = cfl-prediction ++ ravu-lite-ar-r4;
+            };
           };
-        };
 
         config = {
           profile = "gpu-hq";
@@ -174,7 +176,7 @@ with lib; {
       PasswordAuthentication = mkForce true;
     };
 
-    udev.packages = with pkgs; [vial];
+    udev.packages = with pkgs; [ vial ];
 
     xserver.wacom.enable = true;
   };
@@ -213,13 +215,16 @@ with lib; {
     ];
 
     # https://wiki.archlinux.org/title/improving_performance#Watchdogs
-    blacklistedKernelModules = ["sp5100_tco"];
+    blacklistedKernelModules = [ "sp5100_tco" ];
 
     # The boot drive is Samsung SSD 980 PRO 2TB.
-    initrd.kernelModules = ["nvme"];
+    initrd.kernelModules = [ "nvme" ];
 
     # These pools were configured manually with a specific mountpoint.
-    zfs.extraPools = ["udata" "vdata"];
+    zfs.extraPools = [
+      "udata"
+      "vdata"
+    ];
   };
 
   # Filesystem creation:
@@ -265,7 +270,10 @@ with lib; {
     "/" = {
       device = "none";
       fsType = "tmpfs";
-      options = ["size=8G" "mode=755"];
+      options = [
+        "size=8G"
+        "mode=755"
+      ];
     };
 
     "/boot" = {
@@ -276,7 +284,7 @@ with lib; {
     "/nix" = {
       device = "nixos/root/nix";
       fsType = "zfs";
-      options = ["noatime"];
+      options = [ "noatime" ];
     };
 
     ${config.ark.path} = {
@@ -292,7 +300,7 @@ with lib; {
     # [1]: https://github.com/nix-community/impermanence/issues/22
     # [1]: https://github.com/NixOS/nixpkgs/pull/86967#pullrequestreview-667929259
     "/home/${my.username}" = {
-      depends = [config.ark.path];
+      depends = [ config.ark.path ];
       neededForBoot = true;
     };
   };

Consider giving Nix/NixOS a try! <3