summaryrefslogtreecommitdiff
path: root/nixosConfigurations/eonwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixosConfigurations/eonwe/default.nix')
-rw-r--r--nixosConfigurations/eonwe/default.nix52
1 files changed, 48 insertions, 4 deletions
diff --git a/nixosConfigurations/eonwe/default.nix b/nixosConfigurations/eonwe/default.nix
index 8889120..19eb8b1 100644
--- a/nixosConfigurations/eonwe/default.nix
+++ b/nixosConfigurations/eonwe/default.nix
@@ -72,16 +72,60 @@ with lib; {
initrd.kernelModules = ["nvme"];
};
+ # Filesystem creation:
+ # ```
+ # mkfs.vfat -F 32 -l nixos-boot /dev/nvmeXnYpZ
+ #
+ # zpool create
+ # -o ashift=12
+ # -o autotrim=on
+ # -O acltype=posixacl
+ # -O xattr=sa
+ # -O compression=zstd
+ # -O atime=off
+ # -O relatime=off
+ # -O devices=off
+ # -O canmount=off
+ # -O mountpoint=none
+ # nixos
+ # /dev/nvmeXnYpZ
+ #
+ # zfs create
+ # nixos/root
+ #
+ # zfs create
+ # -o mountpoint=legacy
+ # -o relatime=on
+ # -o encryption=on
+ # -o keyformat=passphrase
+ # nixos/root/ark
+ #
+ # zfs create
+ # -o mountpoint=legacy
+ # nixos/root/nix
+ # ```
fileSystems = {
"/boot" = {
- device = "/dev/disk/by-uuid/FF1E-9CFD";
+ device = "/dev/disk/by-uuid/1363-02E6";
fsType = "vfat";
};
"/" = {
- device = "/dev/disk/by-uuid/20276c1b-7e46-430b-b741-2f4aeb76bc51";
- fsType = "xfs";
- options = ["noatime"];
+ device = "none";
+ fsType = "tmpfs";
+ options = ["size=8G" "mode=755"];
+ };
+
+ "/ark" = {
+ device = "nixos/root/ark";
+ fsType = "zfs";
+ neededForBoot = true;
+ };
+
+ "/nix" = {
+ device = "nixos/root/nix";
+ fsType = "zfs";
+ neededForBoot = true;
};
};