summaryrefslogtreecommitdiff
path: root/nixosConfigurations/manwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixosConfigurations/manwe/default.nix')
-rw-r--r--nixosConfigurations/manwe/default.nix88
1 files changed, 88 insertions, 0 deletions
diff --git a/nixosConfigurations/manwe/default.nix b/nixosConfigurations/manwe/default.nix
new file mode 100644
index 0000000..b8dd324
--- /dev/null
+++ b/nixosConfigurations/manwe/default.nix
@@ -0,0 +1,88 @@
+{
+ config,
+ lib,
+ this,
+ ...
+}:
+with lib; {
+ imports = [
+ ./mailserver.nix
+ ./webserver.nix
+ ];
+
+ nixfiles.modules = {
+ nsd = {
+ enable = true;
+ fqdn = "ns1.${config.networking.domain}";
+ };
+ unbound.enable = true;
+
+ wireguard.server.enable = true;
+
+ acme.enable = true;
+
+ monitoring.enable = true;
+
+ postgresql.enable = true;
+
+ git.server = {
+ enable = true;
+ domain = "git.${my.domain.azahi}";
+ };
+
+ gotify.enable = true;
+ matrix.dendrite = {
+ enable = true;
+ domain = my.domain.azahi;
+ };
+ radicale.enable = true;
+ rss-bridge.enable = true;
+ shadowsocks.enable = true;
+ soju = {
+ enable = true;
+ domain = my.domain.azahi;
+ };
+ vaultwarden.enable = true;
+ };
+
+ boot = {
+ loader.grub = {
+ enable = true;
+ device = "/dev/sda";
+ };
+
+ initrd.availableKernelModules = [
+ "ata_piix"
+ "sd_mod"
+ "sr_mod"
+ "uhci_hcd"
+ "virtio_pci"
+ "virtio_scsi"
+ ];
+ };
+
+ fileSystems = {
+ "/boot" = {
+ device = "/dev/sda1";
+ fsType = "xfs";
+ options = ["noatime"];
+ };
+
+ "/" = {
+ device = "/dev/sda2";
+ fsType = "xfs";
+ options = ["noatime"];
+ };
+ };
+
+ swapDevices = [
+ {
+ device = "/dev/sda3";
+ }
+ ];
+
+ zramSwap = {
+ enable = true;
+ memoryPercent = 25;
+ };
+}