summaryrefslogtreecommitdiff
path: root/nixosConfigurations/manwe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixosConfigurations/manwe/default.nix')
-rw-r--r--nixosConfigurations/manwe/default.nix76
1 files changed, 0 insertions, 76 deletions
diff --git a/nixosConfigurations/manwe/default.nix b/nixosConfigurations/manwe/default.nix
deleted file mode 100644
index 3707440..0000000
--- a/nixosConfigurations/manwe/default.nix
+++ /dev/null
@@ -1,76 +0,0 @@
-{ config, lib, ... }:
-with lib;
-{
- imports = attrValues (modulesIn ./.);
-
- nixfiles.modules = {
- nsd = {
- enable = true;
- fqdn = "ns1.${config.networking.domain}";
- };
- unbound.enable = true;
-
- wireguard.server.enable = true;
-
- acme.enable = true;
-
- monitoring.enable = true;
-
- postgresql.enable = true;
- clickhouse.enable = true;
-
- git.server = {
- enable = true;
- domain = "git.${my.domain.azahi}";
- };
-
- matrix.dendrite = {
- enable = true;
- domain = my.domain.azahi;
- };
- murmur.enable = true;
- radicale.enable = true;
- rss-bridge.enable = true;
- shadowsocks.enable = true;
- soju = {
- enable = true;
- domain = my.domain.azahi;
- };
- vaultwarden.enable = true;
- ntfy.enable = true;
- plausible.enable = true;
- };
-
- boot = {
- loader.grub = {
- enable = true;
- device = "/dev/sda";
- };
-
- initrd.availableKernelModules = [
- "virtio_pci"
- "virtio_scsi"
- ];
- };
-
- fileSystems = {
- "/" = {
- device = "/dev/sda2";
- fsType = "xfs";
- options = [ "noatime" ];
- };
-
- "/boot" = {
- device = "/dev/sda1";
- fsType = "xfs";
- options = [ "noatime" ];
- };
- };
-
- swapDevices = [ { device = "/dev/sda3"; } ];
-
- zramSwap = {
- enable = true;
- memoryPercent = 25;
- };
-}