about summary refs log tree commit diff
path: root/nixosConfigurations/manwe/webserver.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--nixosConfigurations/manwe/webserver.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/nixosConfigurations/manwe/webserver.nix b/nixosConfigurations/manwe/webserver.nix
index 5ea2418..324036a 100644
--- a/nixosConfigurations/manwe/webserver.nix
+++ b/nixosConfigurations/manwe/webserver.nix
@@ -1,4 +1,6 @@
 {
+  libNginx,
+  libPlausible,
   inputs,
   lib,
   ...
@@ -79,7 +81,9 @@ with lib; {
           serverAliases = ["frodo.${gondor}" "frodo.${rohan}"];
           locations."/" = {
             root = inputs.azahi-cc;
-            extraConfig = nginxAppendHead [(htmlPlausibleScript {domain = azahi;})];
+            extraConfig = libNginx.config.appendHead [
+              (libPlausible.htmlPlausibleScript {domain = azahi;})
+            ];
           };
         };
       }

Consider giving Nix/NixOS a try! <3